Бухгалтер і комп'ютер.Субота, 20.10.2018, 10:25

Вітаю Вас Гість | RSS
Головна | Статті | Вхід
Меню сайту

Категорії каталога
Бухгалтер і комп'ютер [8]
Все що потрібно бухгалтерам для роботи за комп'ютером
Програмування на 1С [9]
Все що стосується програмування бухгалтерських програм "1С" версій 7.7 і 8.1.

Друзі сайту

Головна » Статті » Програмування на 1С


Унівесальний друк будь якої таблиці в 1C 7.7.

Така потреба найчастіше виникає на етапах налагодження.

Також цей код в мене включений в стандартну обробку «Uchoice.ert»,

для роздруку таблиці перед внесенням змін в базу.

 
Все це оформлено окремою процедурою:

 

//*******************************************

// Призначення:------Універсальний друк вмістимого таблиці-------

// Обовязково добавити: форма для друку "ДрукТаблиці"

// Параметри :

// Табл - таблиця для друку (Тип може бути як ТаблицаЗначений так і таблиця з форми)

Процедура ДрукТаблиці(Табл)

                       

            Если  (ТипЗначенияСтр(Табл) <> "Таблица") и (ТипЗначенияСтр(Табл) <> "ТаблицаЗначений") Тогда

                        Сообщить("Переданий параметром не таблиця");

                        Возврат;

            КонецЕсли;

 

            Таб = СоздатьОбъект("Таблица");

            Таб.ИсходнаяТаблица("ДрукТаблиці");

            Колонок = Табл.КоличествоКолонок();

           

            і = 1;

            Таб.ВывестиСекцию("Шапка|Стовбець");

            Если  Колонок > 1 Тогда

                        Для і = 2 по Колонок Цикл

                                   Таб.ПрисоединитьСекцию("Шапка|Стовбець");             

                        КонецЦикла;

            КонецЕсли;

 

            Табл.ВыбратьСтроки();             

           

            Пока Табл.ПолучитьСтроку() = 1 Цикл

                        і = 1;

                        Таб.ВывестиСекцию("Строка|Стовбець");

                        Если  Колонок > 1 Тогда

                                   Для і = 2 по Колонок Цикл

                                               Таб.ПрисоединитьСекцию("Строка|Стовбець");

                                   КонецЦикла;   

                        КонецЕсли;

            КонецЦикла;   

            Таб.Показать("");

КонецПроцедуры //ДрукТаблиці

 

Як виглядає тепер сама таблиця:

 

 
 
 
Тобто наприклад в будь який звіт , документ достатньо вставити код і саму таличну частину для

можливості роздуку. Виклик думаю зрозумілий «ДрукТаблиці(Таблиця);»

Універсальним способом, звичайно, є перенесення коду в глобальний модуль і добавлення таблиці «ДрукТаблиці» до списку загальних таблиць безпосередньо в конфігурацію.

Категорія: Програмування на 1С | Додав: _Admin_ (17.01.2009) | Автор: Василий
Переглядів: 2471 | Рейтинг: 5.0/1 |
Всього коментарів: 0
Ім`я *:
Email *:
Код *:

Статистика


Copyright MyCorp © 2018